Can only synonymize species in Specify7?

When working with the taxon tree, we’ve noticed that you can only synonymize taxa on species level (or below presumably) and never above species level in Specify7. In Specify6, however, you can synonymize taxa of any level to your heart’s content.

What is the reason for this discrepancy?

Hello @fedoras,
I tested this and I was able to synonymize taxa above the species level in Specify7 with no issues. Could you give us some more details about this so we can attempt to recreate it?
Thanks!

Hi @emenslin

For instance, I want to synonymize the species Achillea millefolia with Achillea millefolium, but having selected millefolia the [Synonymize] button is greyed out:

I presume this is because these species contain subspecies. I could synonymize each subspecies instead, but I really want to synonymize the species itself.

Using Specify 7 Version v7.7.5

Hi @fedoras,

Out of the box, this is the same behavior I encountered when I tested this.

Once you update to Specify v7.8.4 or newer, you can follow these steps to allow you to accomplish what you are looking to do:

  1. Go to :gear_: User Tools and click on “App Resources”
  2. Under ‘Global Resources’, click on ‘Remote Preferences’
  3. Add the following line:
    sp7.allow_adding_child_to_synonymized_parent.Taxon=true
    
  4. Save the Remote Preferences app resource
  5. Clear your browser’s cache (or log out and back in)

Now you should be able to synonymize tree nodes that already have children without any issue! I suspect the database that @emenslin tried this on already had this ‘remote preference’ configured. I tested this on v7.9.3 and verified everything behaved as expected.

Thanks for reaching out!

1 Like