Cannot connect to Specify IT login

I have been using Specify on a single workstation and am now setting setting up sharing with other computers. I have granted permissions to the master user and IT user in MariaDB and edited the my.ini file. I made a mysqldump backup of the Specify database. I reinstalled the Specify application. I’m at the first step of the Specify Wizard. I think I should skip the Create Specify Database since I already have a working Specify database. I clicked the Advanced Test IT Login button. I got Login test was NOT successful. My information is correct. What could be the problem?

I am no longer able to connect to the MariaDB server either with my root account or with the new Master account to which I granted privileges to the specify database. I took my IP address out of my.ini. I still can’t connect.

C:\Program Files\MariaDB 10.8\bin>mysql -uroot -p
Enter password: ********
ERROR 2002 (HY000): Can’t connect to server on ‘localhost’ (10061)

Even when I change the bind-address in my.ini to (“localhost”) I still can’t

On another computer where I also went through the steps for shared access I can still log in at the command prompt but the Wizard says he is unable to connect.


My computer’s IP address is The “/23” needs to be left off, otherwise MariaDB gives the error

ERROR 2005 (HY000): Unknown server host ‘’ (11001)

I tried giving the Master User permission for a range of IP addresses. Had problems using the % wildcard. I tried the slash “/”


MariaDB accepted it, and show grants for user shows the privileges where granted.

MariaDB [(none)]> show grants for ‘username’@‘’;
| Grants for username@ |

but when I Test Master Login in the Specify Wizard I get


Granting permissions for one IP address at a time is OK.

I am able to log in to Specify from one other computer. From another I am able to connect using the MySQL client. I can connect whether I have

Bind-address = [the actual IP address of the computer]

or the Bind-address line commented out

#Bind-address = [IP address]

C:\Program Files\MariaDB 10.6\bin>mysql -h10.116.115.181 -uArundo -p sporobolus
Enter password: ************
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 762
Server version: 10.6.9-MariaDB binary distribution

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [sporobolus]>

However when I try to log in with Specify I get

com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.


It sounds like you need a bit more assistance with setup than the instructions offer. Members can contact us at

I tried to install Specify for the first time for evaluation purposes and encountered the same problem. No matter what I change for the login to succeed, I always get the same error:

Here is a list of things I tried:

  1. Change the bind-address to include both localhost and the (static) IP of the machine.
  2. Try to set the Host name in the wizard to ‘localhost’,, my IP.
  3. Try to use the master user instead of ‘root’.

During these tries, I could connect to MySQL either from the shell or the workbench on the same machine and from a remote device.

Any help crossing this small step and continuing the installation would be greatly appreciated!


Hi @Eyal,

I reccomend following the installation instructions that we have available here on the forum:

We reccomend using the latest version of MariaDB. Specify 6 also supports MySQL 5.7, but not MySQL 8

Let me know if you need some help getting this configured!

Hi Grant,

I think you replied to me by mistake.


Thank you!
I was not aware that a newer version of MySQL is not supported.
I have finally gotten beyond the step of creating the schema.