Still a low limit on dataset size when uploading with Sp7.7.1 WorBench

Two issues when uploading datasets with the Workbench of today’s Sp7.7.1 release:

  1. I can no longer find the tables Exsiccata or Exsiccataitem to map on. However, they were both available in Sp7.7.0’s WB.

  2. I’m trying to upload large datasets containing many columns (almost 100). When the number of records gets just over 1800 (i.e., ca. 180 k cells, almost 2/3 f them empty), the process aborts as soon as the xls file starts importing, with an error message “Request Entity Too Large”. The response in Sp 7.7.1. is different than with Sp 7.7.0. It now aborts right away, so you waste less time, but the limit seems pretty much the same, if not less. Max was explaining he had achieved a succesfull upload of a ca. 8 M cell dataset. I can’t get one accepted with just 1/40th those many. Something I should be doing?

I must compliment Sp7.7.1 with having resolved an issue with many date fields: their null values became automatically populated with today’s date. I kept finding this in query results tables in Sp7.7.0; but no more. It wasn’t even in the’s list of fixed bugs :wink:

The “Request Entity Too Large” error is thrown by the web server, not by Specify.
It happens because the size of the data set you are trying to import is larger than 1MB.
You can change that limit to something like 50M (50 megabytes) by following this guide: https://www.cyberciti.biz/faq/linux-unix-bsd-nginx-413-request-entity-too-large/

(add the client_max_body_size 50M; line in nginx.conf file and restart nginx container)

For the Exsiccata issue, there were some bugs in 7.7.0 in regards to which fields are considered hidden in the WorkBench mapper and the query builder. Those have been fixed in 7.7.1.

The relationship from the Refernce Work table to the Exsiccata table might be hidden in your schema configuration. You can either press the “Reveal Hidden Form Fields” checkbox in the WorkBench mapper, or unhide the relationship using the schema editor.

To open the schema editor, click on your user name, and select “Schema Config” in the user tools menu.
Then, select any schema language.
When prompted for table, select “Refernce Work”.
Find exsiccatae in the list.
Uncheck the "“Hide Field” checkbox.
Save changes.

Screenshot of the checkbox you need to uncheck:

Thanks so much @maxxxxxdlp.
I was making sure Exsiccata and ExsiccataItem were NOT hidden with Schema Config (and of course had Reveal Hidden Forms checked) but I did overlook ReferenceWork, a key piece. I did as you suggested but still no trace of ExsiccataItem table under the Collection Object mapping (including revealed ones).
May be a clue: ExsiccataItem doesn’t show in the list of Base Tables to select for mapping, even with Show Advanced Tables on. All other ones seem to be available as Base Tables, though.

@maxxxxxdlp I was able to recreate Iñigo’s issue with the WorkBench.

@igranzow I have added a bug report to our GitHub:

I will let you know once we have a fix working! Thank you for sharing this with us!

Hi @igranzow,

Thanks to your report, we have fixed this issue!

Any Specify 7 docker instance with the edge tag can pull the latest changes and use this fix now! This fix will be released officially in the 7.7.2 update in the next couple of weeks.