Date format display inconsistent

We like being able to input the date in different ways, but I have noticed a strange behaviour. I don’t know if Specify changed something, or if I did, or if it was always this way, and I didn’t notice.

The default view on our forms looks like this:

But when you double-click the field to type in it, the prompt/format flips the order of dd/mm

Input works fine when user follows the first format, but goes ‘weird’ if you try to follow the format in the 2nd image.

I wonder if it has to do with being in Canada? We will be looking at configuring our database date format, but I’m not clear on how these are interacting.

Eh! Fellow Canadian here :canada:,

Interesting! Our default date format shows as yyyy-mm-dd in the black font, and then turns into MM/DD/YYYY (in grey font) when double clicking. If data is entered in the MM/DD/YYYY format it just gets changed to the yyyy-mm-dd format when focus is changed away from that field.

I know in our workbench it requires the dates to be in the mm/dd/yyyy format when importing data.

1 Like

good ol’ ISO format, yes, I think that is our destination for our database date format.

In the S7 workbench, I have really liked the flexibility for date formats, and generally don’t have an issue there.

For manual data entry in the form, the format itself isn’t the issue, as much as the change, and how it creates inconsistent guidance for users. A lot of our data capture is done by students, so having the interface be as straightforward as possible can be really helpful in reducing errors.

Maybe formally setting our database date format will help, but if you are seeing the similar yet different ‘display inconsistencies’, seems to be something that Specify may have some insight on, or a little bug to fix.

Hi @HeatherC (and @markp),

When double clicking, you shown the database date format configured for your Specify instance. Since you are in Canada :canada:, your browser shows you the mm/dd/yyyy date picker instead of the default American date format of dd/mm/yyyy.

You can configure what date format the WorkBench uses (and the format shown when double-clicking on a date field) by following this guide:

This should resolve both of your issues! Keep in mind that older WorkBench data sets will need to be updated with the new date format in order to upload them after this change is made.

1 Like

Very helpful! Thank you so much!

So what happens is the browser-chosen format is different than the database format?

Wait, US format is mm-dd-yyyy, not Canada (Officially Canada is YYYY-MM-DD).

So if I pick ISO format for the database (like MarkP), yyyy-mm-dd, because I am in Canada, the browser will still show [something else]??

If I want them both to be ISO format, then I would set the database date format, and turn off the user-date-picker?

Thanks for this insight!

Hi @HeatherC,

Interesting – Google Chrome and Firefox should use the ISO 8601 date format (YYYY-MM-DD), so why it did not is very interesting. The browser should detect your region and show the appropriate format.

The browser controls the date format displayed in the date picker, unless you uncheck “Use accessible full date picker” in User Preferences.

Once this is unchecked, after clearing your browser’s cache you should see the database date format instead in your date pickers.

Excellent! So far so good, I followed the instructions for setting the database format, and I think it looks good.

I think I may have also figured out ‘something else’ going on. Because today I am working from home, the the default view (before I made ANY changes) is:

I think what might be happening is that the onsite network may be pinging somewhere ‘else’. LOL

After editing the database format, at least when I am at home, I see the same format when the field is displayed, and when I click the field

I’m going to cross my fingers that this will solve the problem, but am a bit curious, if users were seeing different ‘date display behaviours’ logging in from home, vs. the office, would each user just turn off the “use accessible full date picker” button in their preferences?


ps. I checked in Chrome and Edge, they are both behaving ‘properly’ from home, but also when I connect to my work VPN from home.

Is this a space where I can change the month-year format too? I really don’t like having to enter month text…


I don’t see any other lines in the App Resources preferences that include ‘date’…

I tried just adding this line of text for the month, but it didn’t seem to make a difference to the display above.



Yes! If they turn that off in preferences, it will be consistent regardless of location.

1 Like

Yes! You can disable the accessible month picker as well as a separate preference.