Specify 6 Hardware & Software Compatibility

Specify 6 requires three software components to operate: Java Run-Time Environment (Amazon Corretto or OpenJDK); a DBMS (MariaDB or MySQL); and the Specify 6 application itself. All components are open-source.

Specify 6 does not require or use the Java web browser plugin.


Specify 6 Software Compatibility

Windows 10+

Windows Compatible? Version Compatibility Notes
Specify 6 Applications
Specify Installer Yes
Specify_64 Yes 6.8.01
Specify4GB_64 Yes 6.8.01
SpBackupRestore Yes 6.8.01 File paths for mysql and mysqldump need to be entered for MariaDB, otherwise fine
ImportFileSplitter Yes 6.8.01
SpWizard_64 Yes 6.8.01
SpiReport_64 Yes 6.8.01
DataExporter_64 Yes 6.8.01
Database Manager
MySQL Yes 5.7
MariaDB (recommended) Yes 10.6.5 Removes mysqldump and mysql paths in SpBackupRestore
Java Run Time
Amazon Corretto 8 Yes 8.322.06
Amazon Corretto 11 Yes 11.0.14.9
Amazon Corretto 17 No 17.0.2.8
Recommended Setup: MariaDB 10.6.5, Amazon Corretto 11, Specify 6.8.01

macOS 12

macOS 12 Compatible? Version Compatibility Notes
Specify 6 Applications
Specify Installer Yes
Specify_64 Yes 6.8.01
Specify4GB_64 Yes 6.8.01
SpBackupRestore Yes 6.8.01 File paths for mysql and mysqldump need to be entered for MariaDB, otherwise fine
ImportFileSplitter Yes 6.8.01
SpWizard_64 Yes 6.8.01
SpiReport_64 Yes 6.8.01
DataExporter_64 Yes 6.8.01
Database Manager
MySQL No 5.7-8
MariaDB (recommended) Yes 10.6.5 Requires root password to be set up with Terminal
Java Run Time
Amazon Corretto 8 Yes 8.322.06
Amazon Corretto 11 No 11.0.14.9
Amazon Corretto 17 No 17.0.2.8
Recommended Setup: MariaDB 10.6.5, Amazon Corretto 8, Specify 6.8.01

Ubuntu 20.04.3 LTS+

Ubuntu 20.04.3 Compatible? Version Compatibility Notes
Specify 6 Applications
Specify Installer Yes
Specify_64 Yes 6.8.01
Specify4GB_64 Yes 6.8.01
SpBackupRestore Yes 6.8.01
ImportFileSplitter Yes 6.8.01
SpWizard_64 Yes 6.8.01
SpiReport_64 Yes 6.8.01
DataExporter_64 Yes 6.8.01
Database Manager
MySQL Unsupported 5.7-8
MariaDB (recommended) Yes 10.6.5
Java Run Time
OpenJDK 11 Not Tested ??
Amazon Corretto 8 Yes 8.322.06
Amazon Corretto 11 Yes 11.0.14.9
Amazon Corretto 17 No 17.0.2.8
Recommended Setup: MariaDB 10.6.5, Amazon Corretto 8, Specify 6.8.01

Specify 6 Hardware Compatibility

macOS Yosemite or later release

  • Intel Core 2 Duo processor or later

  • 4 GB RAM preferred, 1 GB RAM minimum

  • Amazon Corretto 8 (JRE)

  • MySQL Server 5.1-5.7 or MariaDB 10 or later

  • ~200 MB disk space for Specify installation

  • ~250 MB disk space for MySQL or MariaDB installation

  • ~1 MB for 500 Collection Object Records (~1 GB for 500,000 records)

  • 1440×900 or 1280×1024 screen resolution preferred, 1024×768 minimum, dual screens of about 23′′ or one screen of 25-30′′ is optimal.

Windows 7, 8, 10 or 11

  • Most any CPU purchased in the last 5 years

  • 4 GB RAM preferred, 1 GB RAM minimum

  • Amazon Corretto 8 or 11 (JRE)

  • MySQL Server 5.1-5.7 or MariaDB 10 or later

  • ~200 MB disk space for Specify installation

  • ~150 MB disk space for MySQL or MariaDB installation

  • ~1 MB for 500 Collection Object records (~1 GB for 500,000 records)

  • 1280×1024 screen resolution preferred, 1024×768 minimum, dual screens of about 23′′ or one screen of 25-30′′ is optimal.

Linux

  • Most any CPU purchased in the last 5 years

  • Tested and supported on Ubuntu and Fedora

  • 4 GB RAM preferred, 1 GB RAM minimum

  • Amazon Corretto 8 (JRE)

  • MySQL Server 5.1-5.7 or MariaDB 10 or later

  • ~150 MB disk space for Specify installation

  • ~100 MB disk space for MySQL or MariaDB installation

  • ~1 MB for 500 Collection Object records (~1 GB for 500,000 records)

  • 1440×900 or 1280×1024 screen resolution preferred, 1024×768 minimum, dual screens of about 23′′ or one screen of 25-30′′ is optimal.