Existing Form Behavior Changes in 7.7

Generate Label on Save

    <cell type="subview" id="attachments" viewname="ObjectAttachment" name="collectionObjectAttachments" initialize="btn=true;icon=CollectionObjectAttachment" colspan="2"/>
    <cell type="field" id="113" uitype="checkbox" name="generateLabelChk" label="Generate Label on Save" ignore="true" default="true" initialize="visible=false" colspan="2"/>
    <cell type="command" id="114" name="generateLabelBtn" label="Generate Label" ignore="true" default="true" initialize="visible=false" colspan="2"/>
    <cell type="subview" id="dnas" name="dnaSequences" viewname="DNASequence" initialize="btn=true;align=left"/>
    <cell type="subview" id="22" name="collectionObjectCitations" viewname="CollectionObjectCitation" initialize="btn=true;align=left"/>

This generate label button present on many forms I have tested have it set to “true” by default, meaning that whenever they save their Collection Object forms it automatically prompts the user to choose a label or report.

Here is how that definition appears in 7.6.1:

Here is how that definition appears in 7.7:

While those two elements (generateLabelBtn and generateLabelChk) are now hidden after the update, when saving the form you are prompted to pick a report.

Another example in 7.7:

As well as in 7.6.1:

When you save your Collection Object, it will automatically prompt you to choose a report or label to print. This can be disabled by changing the item definition:

You need to make the default equal false. The below XML line prevents this behavior:

    <cell type="command" id="generateLabelButton" name="generateLabelBtn" label="Generate Label" ignore="true" default="false" initialize="visible=false" colspan="2"/>

Using label to make fields read-only

If you have a view definition like the one below:

    <cell type="label" labelfor="bgbAltitude"/>
    <cell type="field" id="bgbAltitude" name="text9" uitype="label"/>
    <cell type="label" labelfor="bgbAltitudeInM"/>
    <cell type="field" id="bgbAltitudeInM" name="number9" uitype="label"/>

Because the uitype is label, the fields were not editable in the previous release. If you are relying on this to make fields read-only, you will need to change this in the Schema Configuration tool.

It would appear like this in 7.7:

While in 7.6.1, it would appear like this:

To fix this issue, you only need to correct the form definition to replace uitype="label" with readonly="true".

    <cell type="label" labelfor="bgbAltitudeInM"/>
    <cell type="field" id="bgbAltitudeInM" name="number9" readonly="true"/>